Bug Report about MPI Package Installation

I run this command to install mpi package and receive these errors. Is this a Linux package only? :upside_down_face:

My system is Windows 10 amd64, Octave 5.2.0 64 bit.

pkg install -forge -global mpi
/bin/sh: mpic++: command not found
/bin/sh: mpic++: command not found
MPI_Init.cc:26:10: fatal error: mpi.h: No such file or directory
26 | #include “mpi.h” // mpi.h, oct.h
| ^~~~~~~
compilation terminated.
make: *** [Makefile:24: MPI_Init.oct] Error 1
make: Entering directory ‘/t/Users/Timmy/AppData/Local/Temp/oct-TbAUdU/mpi/src’
C:/MYPROG~1/Octave/mingw64/bin/mkoctfile-5.2.0.exe MPI_Init.cc
make: Leaving directory ‘/t/Users/Timmy/AppData/Local/Temp/oct-TbAUdU/mpi/src’

pkg: error running `make’ for the mpi package.
error: called from
configure_make at line 99 column 9
install at line 190 column 7
pkg at line 441 column 9

Do you have MPI installed on your system?
There is an (ancient) version of OpenMPI for Windows that you can download from here:

I never tried to use it. So I can’t tell if it will work with the mpi package…

Yes, openmpi has dropped windows support. The ancient version 1 does not work any more with Octave mpi package.

There is an openmpi included in cygwin. Any one may try it as alternative.