CamelCase in Octave

During yesterday’s developer meeting, the usage of CamelCase in Octave functions was briefly discussed.
There were no strong feelings about it. But it general it would be nice if underscores could be used in place of CamelCase where possible. Exceptions are made for compatibility with Matlab functions.

This is mainly for consistency in the naming scheme of Octave’s functions.
Since Matlab seems to prefer CamelCase over underscores in functions, using underscores in Octave specific functions might also help to avoid possible name clashes in the future.

@siko1056 recently added JupyterNotebook to Octave that extensively uses CamelCase. Would it be possible to convert that class and its function to Octave’s preferred naming convention? Or are there good reasons for using CamelCase for that part of the code?

Thank you for the hint. Either @Abdallah_Elshamy or I will take care of this :slightly_smiling_face:

2 Likes

Thanks for the suggestion. I thought that was the convention in classdef since inputParser and Map also uses this style. Is that right or using that style was a coincidence?

IIUC, both of those classes are camel-case for Matlab compatibility.

Sorry for the very late reply.

I see. There won’t be a problem with that. Thanks for the hint.

@Abdallah_Elshamy: We are slowly approaching the release of Octave 7.x which will include this new class.
It would cause a lot less hassle if this class was renamed before the release. If this happens after the release, we would need to worry about deprecating the old name for two versions, adding wrappers, …
Could you please prepare a patch that does the necessary renaming?

@mmuetzel, very sorry about the delay. I was moving to another country and things was a bit messy. I will prepare the patch this weekend.

2 Likes

jupyter_notebook.patch (59.4 KB)
I attached the patch. @siko1056 , please take a look at it just to make sure all is fine. I also made the update on a separate branch on the package repo and will merge it later.

1 Like

Thanks for the patch. On Monday I will review it. Have a great start in overseas :blush::+1:

Thank you very much for the patch!

I didn’t test the patch. Just another nitpicking comment:
IIUC, jwe prefers - over _ in file names where possible. - obviously doesn’t work in .m file names. But could you please rename jupyter_notebook.tst to jupyter-notebook.tst?

@Abdallah_Elshamy Thanks for the effort :slightly_smiling_face: I pushed your changes with @mmuetzel suggestion: