Error: 'getinterfaces' with xlsread

Problem description

Hi, when I run

a = xlsread ('FileName.xlsx', 'Sheet1','J3:J6')

I get the following error:

error: 'getinterfaces' undefined near line 306, column 306
error: called from
    xlsopen at line 306 column 14
    xlsread at line 378 column 11
    FileNameOctave at line 67 column 3

.

I already tryied to do the following procedure since suggested in a similar topic but the problem still remain.

pkg unload io
clear -f
pkg load io

My system/settings

  • My IO package version: 2.6.3 (when I type which xlsread,I get the following result 'xlsread' is a function from the file C:\Users\myuser\octave\io-2.6.3\xlsread.m)
  • OS: Windows 10 professional
  • Octave version: e.g. Version 6.1.0
  • Installation method: e.g. Downloaded and installed “octave-6.1.0-w64-installer.exe” from Download
  • on my PC there is installed Microsoft Office

Does that error also occur if you try to use Octave 6.3.0?

If upgrading to the current version of Octave doesn’t help, try de-installing the local installation of the io package (with pkg uninstall io). Instead use the version that is bundled with the installer.
Just load it with pkg load io.

For a list of all packages that are installed, type pkg list.

Before update Octave 6.2.0 to the new version 6.3.0 I tryied to de-installing io and then install it again as you suggested. Now it works properly!
Thank you so much.

There might be a mis-understanding. I didn’t suggest to re-install the io package again. Instead, I tried to advice to use the io package that comes pre-installed with Octave 6.3 on Windows.