GNU Octave not opening

I have Windows 10, and was using Octave GUI for the past week. However, today I cannot open Octave GUI. When I double click on the desktop icon, it seems to open and then shuts immediately:

I have tried the following but they do not seem to solve the issue:

  1. reinstall
  2. turn off McAfee real time

Any help is much appreciated.

Could you try and rename the octave-gui.ini file? It might be that you somehow ended up with a corrupt file.
You can find that file in %APPDATA%\octave.

If renaming that file helps, could you please upload the corrupt file? Maybe someone can figure out what caused the corruption and fix that cause.

Thanks a lot mmuetzel. I renamed the file “octave-gui” to the one you suggested and it seems to work. Over the past week I reencountered the same issue once again, and I had to delete to “octave-gui” file that was created, and that seemed to resolve the issue. I am not sure why is that.

If it happens again, I will upload the corrupt file (apologies I forgot to save it somewhere else).

any chance one of the corrupt .ini files is sitting in the recycle bin?

octave-gui.ini (22.0 KB)

Thanks.

Octave 6.3.0 starts without issues when I replace my octave-gui.ini with that file.

Does it prevent starting the GUI for you reliably?

I just tried again with using the ocatve-gui,ini attached above, and it prevented me from starting Octave GUI. It seems as if octave takes too long to load and then shuts.

Which version of Octave are you using?

6.3.0

This sounds identical to the issue I had last year. Unable to discern from the ini file what the local conflict was.

octave-gui.ini (21.9 KB)

It just happened again. The attached is the new file coming from the new incident.

Have not we seen some issues with using OneDrive with octave?

I recall users reporting issues with messages appearing due to some version of Google Drive that eventually went away. (Maybe related to an automatic update of that software.)

@Orestis: Are you using Google Drive, MS OneDrive, Dropbox, or similar software?

Yes I have MS OneDrive, but I disconnected it from my PC a week ago as I thought of the same. I do not know if that still creates an issue.

I haven’t found the old topic yet but for reference didn’t have one drive or Google drive active when I had the similar issue previously.

Lacking a better idea: Could you try with a nightly build from octave.space? They are built with a newer version of Qt5 (if that should make a difference):
Buildbot (octave.space)

If in doubt, the w64 version is probably the one you’ll need…

Maybe you can try it for a while and see if the error still appears…