Gsl package install problem on Linux Mint 20.1

Linux Mint 20.1 (Ubuntu) uses “libgslcblas0” instead of “lgslcblas” as the name of their linear algebra solver library. Because of this, the gsl library does NOT seem to install:
“checking for cblas_dgemm in -lgslcblas… no”

Byron

Are you sure the library is called libgslcblas0.so for you? I’m on Ubuntu 21.10 and it is called libgslcblas.so.0 for me…
(The package name is libgslcblas0 though. Maybe that is causing the confusion?)

There’s also a precompiled version of the “gsl” Octave package in the repositories called octave-gsl. Would using it also be an option for you?

Hi,

As you are trying to install GSL package from source on Linux, I wonder
whether the problem I reported here :

also affects Linux systems. It seems to be a very basic C++ syntax error, I’m really
surprised I only noticed that on macos …