Having trouble installing control package

I’m trying to install the control package on an M1 mac. The installer wants:
gcc/x86_64-apple-darwin20

The mac has:
gcc/x86_64-apple-darwin21.

Can I change the gcc version Octave is looking for?

I tried simply linking gcc/x86_64-apple-darwin21 to gcc/x86_64-apple-darwin20. The control and signal packages did install with warnings. The signal functions I’m looking for seem to work. I would like to know if there is a “proper” way to fix this though.

I’m running Octave 6.4 with Mac OS 12.1 on a Macbook pro using Rosetta 2.

Thank you for the bug report. How did you install Octave on your MacBook? Do you use Homebrew? Recently, there was already trouble with stale gcc links and Homebrew:

I hope this was fixed with this PR:

If you use Homebrew, can you ensure your installation is up to date?

brew update
brew upgrade

and if there are any warning messages from:

brew doctor

Thanks for the reply! I had already done the sym link and installed the packages I needed. It looks like the pull request has been merged into the master. Will I need to “brew reinstall octave” to get this master?

Thus you are using the Homebrew Octave installation?

Usually the described steps should be enough to get the latest Octave bottle and dependencies.