Help installing symbolic package

Hello I am trying to install the symbolic package but when I use the command pkg install -forge symbolic every single time I get the next error

perl: warning: Falling back to the standard locale ("C").
perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
        LC_ALL = (unset),
        LC_NUMERIC = "C",
        LC_TIME = "C",
        LANG = "es_MX.UTF-8"
    are supported and installed on your system.

Multiple times, I have googled for help but all that I have found says that I have to add the variables to the bash profile but I still get the same error. I am using octave on a apple silicone MacBook Air if that helps. I hope you can help me.
Thanks for your time and attention and sorry for my English, I am not a native speaker.

The good news is that those are only warnings, not errors, and they also look pretty harmless, so nothing in your post indicates that the symbolic package didn’t install. About the warnings, Octave should be able to pick up environmental variables. Can you check a few bash-related things?

  • Did you add export LC_NUMERIC="C" etc to your $HOME/.bashrc or was it a different file?
  • Did you run the command source ~/.bashrc after you edited it, then restart Octave from the updated bash profile or was Octave running throughout? Closing and opening the bash terminal will work too, but Octave should not be open throughout.

Finally, check the symbolic package itself: pkg test symbolic. If that runs (whether it gives test failures or not), then your package is likely installed OK.