New installation; HELP FILEs unavailable within Octave

The internal users’ guide is accessible but not the Help feature.

I also tried to download the PDF version of the Users’ Guide, but the downloading process keeps failing (I have attempted several times, at different times of the day; there is no indication of an Octave server malfunction, just “download failed”)
If anyone can shed some light on this, it would be appreciated.
Octavius

The PDF version of the manual should be installed alongside Octave. You should find a link to the PDF manual in the Windows start menu.

The error message on startup shouldn’t appear.
Does it work if you open Octave with elevated privileges (“Run as Administrator”)?
Did your Anti-Virus software move or delete some of Octave’s files during or after installation? Some Anti-Virus software has a “quarantine” folder. Is that empty?

Ah-ha! I now see that, as you say, the PDF was automatically downloaded into the Octave root folder. Clever. But, the link on the download page still does not work and if that is a permanent error, somebody should either remove the Link to the PDF, or it should be repaired so that it actually works!

  • Regards the error message: No, starting with administrator privileges don’t make a difference, the error still appears.
  • And, there are no items in the Quarantine folder of my Antivirus software.

Thanks for these hints. If you (or someone else) can offer more, please do!

OK, I think that I have discovered the problem, and I believe it is related to the Octave installation routine.
It was after installing Octave that I noticed several problems, not just with Octave, but with other Applications that were trying to write data to a TEMP folder within Windows. These installations included:

  1. MS-Paint
  2. Mozilla Firefox (only when downloading files that were to be saved…apparently, FFox uses TEMP directory as some sort of buffer or cache. For example, I could download a PDF and view it within FFox self-contained PDF viewer, but it would not download to be saved!)
  3. 7-Zip
    Sleuthing this problem chewed up 12 hours of my day, making the day almost an entire write-off. But this work was necessary, as it appeared to be some sort of malware problem.
    The problem is rooted in the ENVIRONMENT VARIABLES of Windows. Apparently, during installation of Octave, these EVs get set to different values. Perhaps the intention is that the installation program would revert those to the original settings afterwards, but it does NOT do that.
    The EVs in question are TEMP and TMP.
    These EVs were set to something like C:…%%AppData%%… [sorry, I did not copy down the path before changing it]
    If both of these EVs are re-set to “C:\Windows\Temp” all of the problems with all of the applications, as enumerated above, are resolved.
    If anybody in this Forum has access to the Octave developers, PLEASE forward this to them, so that they can resolve this problem which (again…) seems to be rooted in the current Installation package for Octave.
    Note that I did NOT experience this problem when I had originally installed Octave about a year ago, but it cropped up when I Uninstalled that older version (followed by a re-boot) and then installed the latest Octave

Thank you very much for this detailed analysis of the issue.

This reminds me of some issues that @PhilipN had with temporary files in windows. But I can’t remember if this occurred while running selected code in the editor or with the help files in the doc browser (@PhilipN, can you help here?).

And, the developers are actually reading this forum :wink:

@Torsten:
your memories weren’t far off I think. IIRC it was about running commands from the GUI editor using the F9 key. But nowadays I also hit it when installing SW.

What I sometimes see is that a system environment variable is “formally” set to C:\Windows\Temp but in Octave the command ‘getenv (“TEMP”)’ returns C:\Windows\Temp\2 - which doesn’t exist.
Also,TEMP and TMP environment variables for normal users (usually %APPDATA%\Local\Temp, i.e., in the USERS’s profile) differ from those used by the administrator account (in the Administrator, Default User, All Users or Public account, I’m not sure). So if you run a installer with admin privileges, it’s not your own temp dir where the temporary unpacked installer files end up.
IOW temp files are a bit of a mess in Windows these days.
Looks like some kind of policy or security thing behind my back. I saw this on my own home PC, not just at work where the IT dept is kind of paranoia these days.

To install Octave (or for that matter, several other SW) with admin credentials I usually open a cmd window as administrator, set TEMP en TMP environment variables (‘set TEMP=…’), and run the installer from the prompt.

Philip

Great, thanks for the prompt feedback— it is good to know that I am not alone!
Maybe some of these hints should be incorporated into the window opened by Octave during the installation; something to the effect that you may want to NOT install via an account that has administrator privileges!
Thanks again,
Mike

Just to be clear: Are you trying to install Octave as a different user than is currently logged in?
Installing with elevated privileges with the same user that is logged in works for me.

I am the only regular user of my computer.
I have administrator privileges.
I am always signed in under my own account, and so I am always signed in with elevated (administrator) privileges.
Does that help

These days, working on any operating system with elevated privileges is a serious security risk.
For your problem it shouldn’t make any difference as there seems to be only one account so there’s no mix-up of TEMP locations.

Philip:
What do you mean by ‘serious security risk’ ? Do you mean the sharing of data from user to user, or the security risk posed to the system by external players (hackers, malware, etc) ?

In the case of working with admin rights, each mistake, from an accidentally executed wrong command to opening a malicious e-mail attachment might have severe consequences for the whole system. Especially allowing malware to change otherwise protected system files is a serious risk.

Ahhh. Something I never knew. “You learn something new every day, even when you are not trying”.
So, it seems that I should demote my usual account to ‘standard user’, and create another with Admin privileges…using the latter only when necessary.

Most operating systems offer the possibility to work as normal user and enter an admin password for temporary admin rights (e.g. when running an installer)

Windows has UAC (user account control) since some time. If you are logged in with an account that has administrative rights, processes are running with user privileges unless they explicitly request administrative privileges (e.g. by using “Run as Administator” from the context menu).
Afaict, there is no need to work with separated administrator and user accounts on Windows (unless you require to deactivate UAC for some reason).

Perhaps you have already resolved an urgent question I was going to post.

Yesterday, I attempted to change my current user profile (OS: Windows 7 Pro, 64 bit) to a normal account, and reserve a separate user account strictly for Admin purposes. This was in accordance with the security alert that TTL gave me yesterday (see his post, above).

The result was this: my current user-profile (operating under “non-admin” restrictions) essentially locked up: all of my task-bar icons froze as blank white rectangles; I had multiple error messages from Windows Explorer and so forth. I was not able to discover a way to resolve this. I do suspect, however, that it had to do with what was probably a very LONG list of file permissions which were no longer available to me under standard-user (not administrator) privileges.

I then attempted to revert to Admin privileges on that user account—the one which I normally use-- but that did not work. In fact, it just seemed to create another layer of problems.

Now, I am not sure precisely sure why all of this occurred, but I do know that I wasted about 3 hours fussing with this, only to have to do a System Restore (reverting to a profile that I had saved 24 hours previously).

I would dearly love to believe that I can merrily continue as before— that is to say, using my Administrator-privileged account for everything I normally do-- as you (mmuetzel) suggest. If anyone has more to say about this, please do.

You wrote above:

I don’t know if that means that you have disabled UAC. If that is the case, enable it or use a separate user account without admin rights like Torsten suggested.
Usually, on a modern Windows, you are not logged in with elevated privileges. Only certain processes are running with elevated privileges. If you are using UAC, you are prompted whether you’d like to grant elevated privileges to processes if they (or you) request it.

I generally set up all of my windows machines with separate profiles, and have no issues, but I haven’t tried to switch one after using it for a while. It maybe carryover habits from before windows (sortof) straightened out it’s UAC situation, but it seems to work ok. I have heard that this is now overkill with Windows 10, but old habits die hard.