Octave 6.2 on Flathub does not work on Linux Mint Cinamon

I installed Octave 6.2 from Flathub on Linux Mint 20.1 Cinamon, but it does not work.

Tried to run it from the start menu: ‘GNU Octave (Flatpak)’, but it does not run and gives no warning messages.

Also tried to run it from terminal: ‘flatpak run org.octave.Octave’, but it does not run and gives no warning messages.

I installed VLC from Flathub, that runs fine.

I did a new OS install of Linux Mint 20.1 Cinamon and again installed Octave 6.2 from Flathub, but it still does not run.

I’ve also confirmed the same problem on Linux Mint 20.0 cinamon.
Another user has confirmed the same problem on Linux Mint 19.3

Please can a fix be made.

The development takes place on GitHub: GitHub - flathub/org.octave.Octave

Thanks for the link, I’ve raised the issue there.

1 Like

Just for reference: Octave 6.2 aborts with SIGILL from OpenBLAS 0.3.13 on older CPUs · Issue #131 · flathub/org.octave.Octave · GitHub

It turned out an older (~10 years) CPU was involved and OpenBLAS had a problem with it.

And this is now fixed, should work on any x86-64 again.