Octave 7.1.0 GUI unable to launch (no vbs issues)

Hello !

Problem description

  • After clicking Octave-GUI shortcut, the window open then close after 1 or 2 sec.
  • It was working before, the only thing I’ve installed before noticing the problem is JRE 8u333
  • I already tried to desinstall/reinstall/update both Octave and JRE
  • I’ve seen another topic with the same problem but here VBS files are properly running
  • The only AV on my laptop is Windows Defender and I already places the Octave folder in the exceptions list
  • Already tried to desactivate Defender and HP wolf security but it still doesn’t work
  • Octave-CLI is properly running
  • The first screenshot shows what I can see from the Event Viewer when I try to open Octave GUI
  • The second screenshot is en error message I recieved only once, I don’t know if it has to do with the main problem

My system

  • OS: Windows 11 professional 10.0.22000
  • Octave version 7.1.0
  • Installation method: e.g. Downloaded and installed “octave-7.1.0-w64-installer.exe” from Download

Thanks in advance for your support !


ScreenshotError

1 Like

IIUC, another user described similar issues:
bug #62604, Octave GUI closes by itself [Savannah]

IIUC, they could “fix” it by renaming the octave-gui.ini and letting it be recreated with default settings. That file is usually created in %APPDATA%\octave\octave-gui.ini. By default, the environment variable %APPDATA% is set to something like C:\Users\*username*\AppData\Roaming (where *username* is your Windows user name).

It works thank you so much ! :slight_smile:

I don’t know if it will provide any insight, but if you still have the old ini file and are comfortable posting it here along with the current working one, perhaps a comparison will help provide some indication of what’s causing this intermittent problem.

Good idea ! Here are the two .ini files. The one named “octave-gu.ini” is the old one and the other correctly named “octave-gui.ini” is the new one.
octave-gu.ini (6.8 KB)
octave-gui.ini (4.3 KB)

@ttl if you get a chance to look, anything obvious here? I added an hg diff of the two (since that’s what I’m used to reading)
octave-gui_ini.diff (8.8 KB)

main differences I’m seeing, other than specific values of Window geometry/state etc fro tthe different windows and widgets, is the presence of a saved session tab in the Editor, and a bunch of Scintilla style settings at the end that aren’t in the default ini file.

if you don’t mind helping test a bit, does the crashing resume if you put the old ini file back? and does simply swapping back in the ‘good’ ini file make it work again? Previously we’ve not seen anything obvious in the ini files, and I was wondering if it’s the ini file itself or something else that’s fixed when Octave doesn’t see the ini and runs through the ‘first time’ process.

I have a big math exam tomorrow in the morning with Octave. Is it ok for you if I try after tomorrow ? :slight_smile:

no problem. Obviously, other things come first.

There is nothing obviously wrong in the old ini file. The terminal widget’s geometry has negative coordinates but this is also the case for other dock widgets in the new file. Maybe this is a problem for the terminal, I do not know to be honest. Other than that, it is not possible to judge whether the binary data in the main window’s geometry and state looks sane or not.

If restoring state and geometry of the main window and its widgets causes these crashes at startup, the related code sequences could be enclosed in a try-catch block where the catch block just resets the window layout to the default one. I am going to prepare a patch for this.

Btw, the old (possibly corrupted) ini-file is working on my old Win 7 VM.

Yes that’s why I was wondering if putting it back would cause a crash again on his particular system. If not, then it suggests the problem is not the INI file, but that whatever is the problem is cured by triggering the “no octave-gui.ini found” process.

I was not able to replicate the error. The old ini file is working too here.

ok, thanks for checking.

@ttl, I think we discussed this a while ago, but what exactly happens when the ini is missing? what else could be occurring that could ‘reset’ an erroring condition, where ini isn’t actually the problem but its removal causes the actual problem to get fixed?

AFAIK, the location and name of settings file is determined and from that on it is accessed by the methods provided by Qt, mainly value (), a few time contains (). If a setting is not found when requested by value () a default value is taken. I am not aware of any action that changes a persistent state of octave that could explain why the same ini file suddenly works again.