Octave CLI and GUI does not open from desktop shortcut after installation on MS Windows 10

ok. so script engine is there. the executable seems to run. the file association is right. but nothing happens when attempting to run. Now to figure out what is blocking execution…

no change when checking on the windows defender setting i linked a few comments up? (the how-to geek article)

some security settings are supposed to pop up a ‘scripts blocked’ type warning. so getting nothing is frustrating.

It’s probably not this, but can you check that shell scripts are enabled in the registry?

(editing the registry can cause problems. please don’t make any changes doing the following, just report what you see)

Win+R to get a run dialog, type regedit and click ok.

Navigate to the two following locations using the folder tree on the left:

User setting:
HKEY_CURRENT_USER\Software\Microsoft\Windows Script Host\Settings\

Machine:
HKEY_LOCAL_MACHINE\Software\Microsoft\Windows Script Host\Settings\

Do either of those have a key named Enabled under Settings, and is the value for that key 0? If the key doesn’t exist, or is set to 1, then this isn’t your problem. if it is set to zero, then execution will be blocked. BUT it’s supposed to popup the following message whenever execution is attempted:

Windows Script Host access is disabled on this machine. Contact your administrator for details.

and you aren’t getting any messages at all.

I checked. this is not the problem.

might make a stackoverflow post on this one to see if the hive mind can figure out what would be disabling vbs scripts and where those settinng controls are. I’d expect this on a managed system, but not a more-or-less-default setup personal pc.

@Hrithik_Advani, can you reply with exactly which version of Windows 10 you’re running?
Win+X, System, scroll part way down to “Windows Specifications” and post what’s shown.

Also, for Windows Defender (or Microsoft Defender I guess it’s called now): Open the defender security center app (double click the shield icon in the notification area), select the Settings gear icon in the bottom left, then About. System information should list a bunch of versions. please post that as well.

image

one other thing to check for clues. Try to open octave again. Then open the Windows Event Viewer (should also be in the Win-X list, it can take a minute to populate). i never know exactly where to find things in there, but check the different Windows Logs, maybe Application or Security. Clicking on those logs should show events in the center pane with most recent at the top. Click on anything that occurred in the last minute or so and see if anything looks related.

when you said you tried turning of your AV and saw no change, how exactly did you turn it off. was it similar to the procedures stated here?:
https://support.microsoft.com/en-us/help/4027187/windows-10-turn-off-antivirus-protection-windows-security

Also, superuser question posted here:

I did the same thing for anti virus. Thank you creating a post on superuser.

can you open a command prompt and check the following environment variable with the following command:
echo %PATHEXT%

you should get a list of extensions and .vbs should be in there

I saw this one on superuser. I checked this and .vbs is there.

another superuser suggestion offered as an answer. i think we’ve checked those things which are mainly file association, but in case they’d show something different may be worth trying:

i think we checked that wscript.exe exists in c:\windows\system32

but also:

ftype | find /I "VBS"

That should give the result:

VBSFile="%SystemRoot%\System32\WScript.exe" "%1" %*

Then, check

assoc .vbs

which should show:

.vbs=VBSFile

ok good. another comment popped up:

Does the sample script run if you execute it like this from CMD Prompt or Run: wscript.exe C:\test.vbs (or) cscript.exe C:\test.vbs

I know you tried running the vbs script directly and got nothing, but lets just verify that explicit call. and checking cscript is also a good idea, although I don’t know if octave gui would run right with cscript

Hi, Hrithik_Advani

Pls include this line in the demo vbscript you made:

wscript.echo "Test Message"

From Command Prompt run it as:

cscript path_to_file_name.vbs

If you get no response, try Sfc scan on vbscript.dll from Administrator Command Prompt.

sfc /scanfile=c:\windows\system32\vbscript.dll


Nothing pops up.

adding wscript.echo “Test Message” does not correct the issue. trying sfc /scanfile=c:\windows\system32\vbscript.dll shows “Windows Resource Protection did not find any integrity violations.”

If you as well as the forum admin agree, I have a suggestion.

Can you get the ProcMon trace of wscript.exe or cscript.exe (whichever you’re going to try) and upload the PML log file (zipped) to the web?

More info on generating a ProcMon log is here.

If you mean me, I don’t need to approve anything. We’ve already exceeded the limits of my knowledge here. I’m little more than a superuser relay at this point :slight_smile:

Logfile.zip (800.8 KB)
I created a demo file which looks as following and try to run that and captured the events that follow.

i=10

If i=10 Then
wscript.echo “Test Message”
msgbox(“This is my first script, Click OK to close”)

Else
wscript.echo “Test Message1”
msgbox(“Hello world”)

End if

The log shows 3 Avast antivirus DLLs and 1 McAfee module loaded by wscript.exe. But noticed your earlier post saying you have inbuilt anti-virus only (Defender).

Still going through the log.