Octave CLI and GUI does not open from desktop shortcut after installation on MS Windows 10

when you said you tried turning of your AV and saw no change, how exactly did you turn it off. was it similar to the procedures stated here?:

Also, superuser question posted here:

I did the same thing for anti virus. Thank you creating a post on superuser.

can you open a command prompt and check the following environment variable with the following command:
echo %PATHEXT%

you should get a list of extensions and .vbs should be in there

I saw this one on superuser. I checked this and .vbs is there.

another superuser suggestion offered as an answer. i think we’ve checked those things which are mainly file association, but in case they’d show something different may be worth trying:

i think we checked that wscript.exe exists in c:\windows\system32

but also:

ftype | find /I "VBS"

That should give the result:

VBSFile="%SystemRoot%\System32\WScript.exe" "%1" %*

Then, check

assoc .vbs

which should show:


ok good. another comment popped up:

Does the sample script run if you execute it like this from CMD Prompt or Run: wscript.exe C:\test.vbs (or) cscript.exe C:\test.vbs

I know you tried running the vbs script directly and got nothing, but lets just verify that explicit call. and checking cscript is also a good idea, although I don’t know if octave gui would run right with cscript

Hi, Hrithik_Advani

Pls include this line in the demo vbscript you made:

wscript.echo "Test Message"

From Command Prompt run it as:

cscript path_to_file_name.vbs

If you get no response, try Sfc scan on vbscript.dll from Administrator Command Prompt.

sfc /scanfile=c:\windows\system32\vbscript.dll

Nothing pops up.

adding wscript.echo “Test Message” does not correct the issue. trying sfc /scanfile=c:\windows\system32\vbscript.dll shows “Windows Resource Protection did not find any integrity violations.”

If you as well as the forum admin agree, I have a suggestion.

Can you get the ProcMon trace of wscript.exe or cscript.exe (whichever you’re going to try) and upload the PML log file (zipped) to the web?

More info on generating a ProcMon log is here.

If you mean me, I don’t need to approve anything. We’ve already exceeded the limits of my knowledge here. I’m little more than a superuser relay at this point :slight_smile:

Logfile.zip (800.8 KB)
I created a demo file which looks as following and try to run that and captured the events that follow.


If i=10 Then
wscript.echo “Test Message”
msgbox(“This is my first script, Click OK to close”)

wscript.echo “Test Message1”
msgbox(“Hello world”)

End if

The log shows 3 Avast antivirus DLLs and 1 McAfee module loaded by wscript.exe. But noticed your earlier post saying you have inbuilt anti-virus only (Defender).

Still going through the log.

Thanks for the response, nrjank :+1:
Working on the log. Let’s see if I can spot anything.

Thank you so much for help. you solved the problem. “McAfee” was causing the real problem. I deleted that and everything is working now. I had no idea where “McAfee” came from and could have caused the problem. Thanks @nrjank as well. You constantly supported me trying to solve the problem.

great to hear it. to help us if this comes up again - did you ever have mcaffee antivirus or avast installed? was it maybe ‘bundled’ with your purchased system and was still hanging around? windows supposedly only leaves one antivirus in control. but you thought Windows built in AV was in charge?

if you’re not intentionally using it, I’d recommend removing avast as well. best just to leave one tool in charge.

Thanks for the detective work. If you’re on superuser and want to write it up as an answer with the procmon details I’ll mark it as correct.

Thanks for the update. Glad the issue is fixed now.

Very welcome nrjank.

Posted on SU:

1 Like