Octave GUI has been not working!

Problem description

I do not understand why was it like that, it still worked well 2 days ago!
But I did not respond yesterday, I uninstalled and install it many times, it has not changed!
I read and referred to other guys’ problems, but it does not really suit my problem!
(I tested running Test.vbs, it worked; but octave.vbs was excepted)
I still can open CLI, I tried naming the extension of a ‘.m’ file to ‘.txt’, it worked perfectly :slight_smile:
But I cannot open the file ‘.m’! Please tell support me to figure out the problem.
Thank you!

Thank you for your problem report. Can you answer some questions to help us helping you:

  1. What is your operating system? (I guess it is Microsoft Windows?)

  2. Which version of Octave do you use?

  3. What exactly is not working? (You write about the “Octave GUI” in the title, but drift to files with .m-extension and octave.vbs.)
    Please give a clear procedure of what steps you did (like double-clicking the Desktop Icon of Octave GUI) what happened and what did you expect to happen.

  4. If you write you read about “other guys’” problems, please post a link to what you have read.

1 - Yes, I’m using Windows 10 Pro, ver 2H20
2 - I reinstalled yesterday so I’m using newest version (6.3.0).( because I could not ran it !)
3 - it hangs a bit and close automatically! It worked once this morning, but when I closed and ran again, it didn’t work!

4 - Octave CLI and GUI does not open from desktop shortcut after installation on MS Windows 10 - #50 by Hrithik_Advani - this guys, but his problem is just from his anti-virus software, I checked and uninstalled mCafee from my device, but it have not worked yet!
‘.m’ file from Coursera - I’m following a course and it uses Octave to practice. It’s Octave file too; some weeks before, I still open my assignment 1 easily, but next to assignment 2, 3 there are some problems appearing, and worst is I can not open
Octave!

Thank you for the information. Thus the Octave GUI opens once in a while for you but closes automatically after an arbitrary short time.

Do you have any other “AntiVirus” software (except for the on board “Windows Defender”) installed? If so please make sure that your “AntiVirus” software is properly updated and none of Octave’s file has been put into a “quarantine” or similar feature of that “AntiVirus” software.

After that I would try to uninstall everything related to Octave and make a clean system reboot.

On the freshly rebooted system, install Octave again and see if things improved.

I did all things I can but it has not worked!
I think this is from my own system, I’ll try to fix it later! (it worked perfectly before, and as you know it has just suddenly stopped working yesterday)
I should use ‘txt’ file temporarily and when I figure out the solution I’ll put it here to everyone, who has the same problem as me :slight_smile:
Thank you a lot!

An old Japanese haiku I remember (Kobayashi Issa ? – not sure)

Yesterday it worked
          Today it doesn't
                 Windows is like that
2 Likes

:smile: it’s programming, it’s software!

It might be that somehow your GUI settings were botched.
Could you please try and rename octave-gui.ini that should be installed at %APPDATA%\octave?
Does that allow to start the GUI again?
If it does, could you please upload the version of that file that caused the troubles? Maybe someone is able to deduce what is causing the error from that file.