Pkg installation

i want to install symbolic pkg
sympy & python have been in place
using “pkg install ~~” caused the folllowing error
please help me

Some ideas about the error:

  1. Your downloaded “tar.gz” file is damaged. Download it again.
  2. You don’t have write permissions on the temporary or target directory.
  3. Some “AntiVirus” software blocks your actions. Can you check with your software in this case?

Another useful source of information is here:

Thanks for answer.
by “write permissions” do you mean ''addpath"? the current directory has been in path but don’t work. do i need to do anything more to “write permission”?

On a few occasions we have seen Windows setups that have problems installing packages because there are permissions issues with the temp folder used to compile the package. Some security settings limit temp folder activities. I don’t think that’s supposed to affect symbolic because last check it didn’t have co.piled code. But maybe it’s related?

You can check this by making a temporary folder elsewhere, and changing the octave tempdir setting to that, and seeing if anything changes. My work managed system has that problem, so I created a C:\Octave\Temp folder.

Then after running

setenv(“TMPDIR”, ‘c:\octave\temp’)

Try running the pkg install command again. If there’s question about the tar.gz integrity, you can always run

pkg install -forge symbolic

To download and install directly in one step.

We have also seen issues with windows machines not seeing recently changed/created files on network drives, but unless your profile temp folder is on a network drive I can’t see that applying.

This could also be a problem with non-ASCII characters in directory or file names on Windows.
In a recent bug report, it turned out that glob fails for non-ASCII characters on Windows. copyfile calls glob immediately before the error you showed is thrown.

Does your Windows user name contain non-ASCII characters?

Even if this should turn out to not be the cause of the original reporter’s issue, I opened a bug report about functions using glob on Windows here: https://savannah.gnu.org/bugs/index.php?59287

thanks for warning.
although i didn’t ask for help, the non-ascll problem did bother me a lot before

thanks, perfectly solved

what exactly fixed it? setting a different temp folder?

yes, setting a different temp folder works

Does that mean that your Windows user name contains non-ASCII characters?