Snap version GNU Octave didn't read ~/.octaverc

Hi everyone. I intend to load symbolic package on startup by using ~/.octaverc file. The GNU Octave from apt worked fine, but the Snap one didn’t. Is there anything I can do to make it read ~/.octaverc file?
Thank you very much.

My system

  • OS: Ubuntu 20.04
  • Octave version: Version 6.3.0
  • Installation method: Installed from Snap

IIUC, snap runs Octave in a sandbox. Try running edit ~/.octaverc from Octave’s command prompt. That should be opening the “sandboxed” version of the .octaverc file…

Right, more specifically, snap creates a private home directory for each revision of each program. So the startup file that Octave loads in snap context is /home/$USERNAME/snap/octave/current/.octaverc.

1 Like

@mmuetzel @mtmiller . This helped me a lot. Thank you very much.

OS: Kubuntu 20.04
Octave version: Version 6.4.0
Installation method: Installed via `snap install octave'

I tried edit ~/.octaverc and was presented with a ‘create file’ window. Pressing ‘create’ immediately produced a ‘save file’ window without the opportunity to edit the file. Pressing ‘save’ produced ‘error: edit: could not create .octaverc’.

I tried creating the file manually in /home/$USERNAME/snap/octave/current but on startup Octave says:
error: source: error sourcing file ‘/home/[USERNAME]/snap/octave/245/.octaverc’

Any ideas?