Symbolic in Jupyter

Hello everybody.
Does anyone know why the symbolic package doesn’t work in jupyter?
In Octave GUI if this code works:

pkg load symbolic
syms x;
eqn = 100 == x ^ 2;
val = vpa (solve (eqn, x), 5);

But when I run it in jupyter I get an error.

Python not found; run without arguments to install from Microsoft Store or disable this shortcut in Settings> Manage application run aliases.
error: Cannot run the Python executable “python3”
Thanks for your time


Are you using Windows? ok better i make a list about things that need to be sorted:

  1. What operating system are you on?
  2. How did you install python?
  3. How did you install/are running jupyter?
  4. How did you install the symbolic package?

Because the maintainers of the symbolic package say that the windows installation sometimes needs some particularities.

Thank you very much for your answer, regarding the answer to your questions.

  1. What operating system are you on?
    I have installed GNU Octave on Windows 10

  2. How to install python?
    Install python through miniconda, a kind of anaconda but lighter.

  3. How did you install/are running jupyter?
    Install jupyter through miniconda 3 console.

conda install -c conda-forge jupyterlab

Then you install GNU Octave and create an environment variable for the executable.
Then install the octave kernel.

pip install octave_kernel
python -m octave_kernel install

  1. How did you install the symbolic package?
    Download the .zip and install it in GNU Octave

Thank you

no se encontr python

Can you check if the windows environment variable has an entry for python3 ?

Ok i suppose every piece of software works individually ok,

I tried several approaches and they work, ok these are the steps i followed:

1.- I’m on Windows, i downloaded the GNU Octave 6.3.0 and installed it, i changed the installation directory to one without spaces in its name, as:

C:\Octave\Octave-6.3.0

2.- Before installing other software i install the symbolic package not by running the forge command, but instead by going to the download page of the project as it says that windows can have some problems with the dependencies the package requires, which i guess from the error in your message is the case the package isn’t working.

In this case download the latest symbolic package file symbolic-win-py-bundle-2.9.0.tar.gz file from Releases · cbm755/octsympy · GitHub

3.- I move the symbolic-win-py-bundle-2.9.0.tar.gz file to an appropiate directory, and i open Octave, i change my working directory to the directory containing the symbolic package installer and i run in the octave command line:

pkg install symbolic-win-py-bundle-2.9.0.tar.gz

Octave unpacks and installs the symbolic package.

At this point i test that the installation is correct by running commands like:

pkg load symbolic
syms x
factor(x^2-x-6)

4.- I verified that the symbolic package installed from the tar works fine, then I install miniconda, since the newest one uses python 3.9 I think but that one still has some issues and some packages I need require an older python I go for the miniconda installation with python 3.7.

5.- Once miniconda has been installed i install jupyter notebooks with the jupyter lab command you used

conda install -c conda-forge jupyterlab

6.- When jupyter has finished installing I install the Octave kernel, i recommend not mixing packages in miniconda via pip and conda installation commands on top of each other, instead of using pip i run the command:

conda install octave_kernel

you also mentioned that you have already set the enviromental variable pointing to the octave executable so the jupyter notebook should be able to load the conection to octave.

7.- Finally i run the same example to check that everything works:

1 Like