Windows 10 silent install 6.1.0 hangs

Installer never finishes

I am trying to install GNU Octave 6.1.0 through Powershell with the command:
Start-Process -FilePath “.\octave-6.1.0-w64-installer.exe” -ArgumentList ‘\S’ -Wait
The application is installed and works as intended, but the Start-Process never finishes. I have discovered that version 5.1.0 had the same issue last year. I tested the 5.2.0_1-w64-installer as well, but it seems to have the same problem.

EDIT: To clarify, my goal is to install Octave silently. Does not matter which version. Have now tried silent install with these installers:

  • Octave-5.1.0-w64-installer.exe
  • Octave-5.2.0_1-w64-installer.exe
  • Octave-6.1.0-w64-installer.exe

Still no luck.

My system

  • OS: Windows 10 (version 20H2)
  • Octave version: Version 6.1.0
  • Installation method: Downloaded and installed “octave-6.1.0-w64-installer.exe” from https://www.octave.org/download.html

This thread is no longer applicable to me as I managed to manouver around it. However this is still an issue for these installers.

(If anyone looks this up for a solution: I used a simple Do-While to find the installer-process and check every 10 seconds if the process still ran until it didn’t.

# Start the installer
Start-Process "octave-6.1.0-w64-installer.exe" -ArgumentList "/S"
# Give the process time to start
Start-Sleep 3

Do { 
   $ProcessFound = Get-Process | Where-Object { $_.Name -Match "octave-6.1.0*" }
   If($ProcessFound) {
      Start-Sleep 10
   }
} Until (!$ProcessFound)

To be clear, the issue is that when using the -Wait option in power shell, it never returns back from installer?

Not using powershell, I can run it as:

start “” /WAIT octave-2020-12-02-07-41-w64-installer.exe /S

If I understand you correctly, maybe? I think -Wait simply exposes the fact that the installer process doesn’t let Powershell know that it is done (Wild guess; exit code related on either the installer or descendants?).

This is fetched from Microsoft doc regarding Start-process -Wait

Indicates that this cmdlet waits for the specified process and its descendants to complete before accepting more input.

On install, as part of the msys start up it starts a pgp service - I wonder if that running is counted as a ‘decendant’ ?

Hi, with 6.4.0, -wait still won’t work.

start-process returns an object, but e.g. without Exitcode. The 2nd line in the below code wokrs. 3rd doesn’t.

$processReturn = start-process ocatve-installer.exe -Passthru
do {Start-Sleep 10} while (Get-Process -inputObject $processReturn)
$exitCode = $processReturn.ExitCode

br Bernhard